Installation dependencies

The official installers for Windows and OSX should already come with/install the necessary dependencies for base functionality to work.

Note

Plugin dependencies should be listed in their description

Dependencies

Essential:

  • python (== 2.7.x)
  • bsddb (distributed with stdlib) or bsddb3
  • gtk+ >= 3.10
  • gstreamer >= 1.4
  • gstreamer-plugins-base >= 1.6
  • gstreamer-plugins-good >= 1.4
  • mutagen (>= 1.10)
  • dbus-python
  • pygobject (>= 3.13.2)
  • python-cairo
  • GI typelib files for GTK+, GStreamer (including gstreamer-plugins-base) and cairo (python-gi-cairo on Ubuntu)

Translation:

  • gettext

Documentation:

  • sphinx
  • sphinx_rtd_theme
  • help2man

Device detection (one of the following):

  • hal
  • udisks
  • udisks2

CD info:

  • python-cddb

DAAP plugins (daapserver and daapclient):

  • spydaap

Last.FM integration:

  • pylast

Lyrics from lyrics.wikia.com (lyricwiki):

  • Beautifulsoup4

Musicbrainz covers:

  • musicbrainzngs

Podcast plugin:

  • feedparser

Wikipedia info:

  • webkit2gtk + its GI typelib

Xlib-based hotkeys:

  • keybinder + its GI typelib

Scalable icons:

  • librsvg2

Test dependencies:

  • mox3
  • pytest